[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: can not install cross toolchain [Solved]

On Tue, 2010-02-16 at 13:40 +0100, Tom wrote:
> Hi,
> i have a i386 ubuntu 9.10 installed and want to compile a linux kernel
> for armel.
> i followed the instructions from [1] but get the following error:
> $ sudo apt-get install libc6-armel-cross libc6-dev-armel-cross
> binutils-arm-linux-gnueabi gcc-4.3-arm-linux-gnueabi g
> ++-4.3-arm-linux-gnueabi 
> Reading package lists... Done
> Building dependency tree       
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
> The following packages have unmet dependencies.
>   g++-4.3-arm-linux-gnueabi: Depends: libstdc++6-4.3-dev-armel-cross (=
> 4.3.4-6) but it is not going to be installed
>   gcc-4.3-arm-linux-gnueabi: Depends: libgcc1-armel-cross (>= 1:4.3.4-6)
> but it is not going to be installed
>   libc6-armel-cross: Depends: libc-bin-armel-cross (= 2.10.2-5) but it
> is not installable
>                      Depends: libgcc1-armel-cross but it is not going to
> be installed
>   libc6-dev-armel-cross: Depends: libc-dev-bin-armel-cross (= 2.10.2-5)
> but it is not installable
> E: Broken packages

i removed all emdebian entries from my sources.list, made apt-get
update, insert the emdebian entry (stable) to the sources.list again and
then the installation worked! No i can cross compile the linux kernel
for armel.

> [1] http://www.emdebian.org/tools/crosstools.html 

Reply to: