[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Impossible to install emdebian's toolchain on Lenny

I should have supplied the following information. The sources.list line is:

deb http://www.emdebian.org/debian/ lenny main

If I start with a clean system that has no packages from the emdebian project then:

bi35-sensorinfo:~# apt-get install libgcc1-armel-cross
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
  libgcc1-armel-cross: Depends: gcc-4.4-base-armel-cross (= 4.4.1-1) but it is not installable
E: Broken packages

The availability of this toolchain has made life much simpler for us (deeply grateful) so we are eager to have this resolved.

Thanks again,


--- On Fri, 8/28/09, Wookey <wookey@wookware.org> wrote:

> From: Wookey <wookey@wookware.org>
> Subject: Re: Impossible to install emdebian's toolchain on Lenny
> To: debian-embedded@lists.debian.org
> Date: Friday, August 28, 2009, 10:55 AM
> +++ Pierre Pronchery [2009-08-28
> 15:20 +0200]:
> >        
>     Dear developers,
> >
> > I can't install emdebian's stable toolchain anymore:
> Sorry. Yes, this happens from time to time (far too often
> in fact).
> We need to know which emdebian repositories you are
> pointing at (check
> /etc/apt/sources.list and /etc/apt/sources.list.d/*
> >
> > Is this a known issue, can I do anything to help
> fixing this? (better  
> > place for bug reports...)
> Following through the dependencies to work out exactly what
> the
> problem is would be useful.
> The usual problem is that gcc builds, even of old
> toolchains, always
> end up depending on the latest version of libgcc1
> available. 
> This is the right place for bug reports of this nature,
> although
> putting them in debian's bug system against the package
> buildd.emdebian.org is also useful. 
> Wookey
> -- 
> Principal hats:  iEndian - Balloonboard - Toby
> Churchill - Emdebian
> http://wookware.org/
> -- 
> To UNSUBSCRIBE, email to debian-embedded-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: