[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Cross-building toolchain



On Fri, 6 Mar 2009 11:01:51 +0100
Frans Pop <elendil@planet.nl> wrote:

> (Please CC on replies.)
> 
> On Friday 06 March 2009, Neil Williams wrote:
> > Do you need gcc-4.1 for a particular reason?
> 
> The .26 Debian kernel for s390 was built using 4.1. I've built newer 
> versions with 4.2, but have been seeing errors that look like they might 
> be related to gcc, so I'd like to try using the older version.
> I understand there were good reasons to stay with 4.1 for kernel builds 
> for some arches.

> Alternatively I'd like to try with 4.3, but I noticed the 
> gcc-4.3-s390-linux-gnu package currently isn't available for amd64.

Hopefully Hector will be able to provide more information on that
problem. Some combinations of toolchains simply don't build and it can
be very hard to work out why.

> There seems to be another minor issue though. I wanted to search for any 
> s390 packages, so I typed that in the search box:
> http://www.emdebian.org/toolchains/search.php?arch=amd64&distro=sid&package=s390

Hmmm, yes, I'm aware of niggles like that with the search routine, need
to find some time to fix the code. (in Emdebian SVN if anyone wants to
help identify the problem but note that the same script runs the
searches for Crush, Grip and TDebs as well as toolchains).

http://buildd.emdebian.org/svn/browser/current/website/trunk/english/toolchains

-- 


Neil Williams
=============
http://www.data-freedom.org/
http://www.linux.codehelp.co.uk/
http://e-mail.is-not-s.ms/

Attachment: pgpIpMIwkbHCL.pgp
Description: PGP signature


Reply to: