[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Default target suite debconf question



On Wed, 17 Oct 2007 10:17:21 +0100
Wookey <wookey@wookware.org> wrote:

> On 2007-10-16 16:41 +0100, Neil Williams wrote:
> > The new apt-cross/emdebian-tools code needs a reliable method of
> > identifying the suite to use when comparing versions, downloading
> > cross-dependencies during a build and selecting toolchain packages.
> > 
> > The default should be unstable, in line with Debian where the default
> > build suite for all uploads is sid. Codenames need to be static and
> > support all cross-building architectures so I've chosen 'unstable',
> > 'testing' and 'stable' as the debconf selections. How this relates to
> > Ubuntu is unknown - the toolchains are built for Debian and may or may
> > not be installable on any particular Ubuntu flavour.
> > 
> > I'm unsure how to phrase the debconf question:
> > 
> > _Description: Build packages against Debian unstable?
> >  emdebian-tools follows Debian by defaulting to building against
> >  unstable. This setting determines the versions of libraries and
> >  packages linked against the cross-built emdebian packages.
> > 
> > That's probably insufficient help.
> > 
> > Improvements welcome.
> 
> OK. How about:
> _Description: Which suite (e.g. unstable) should we build packages against?
>  This setting determines the versions of libraries and
>  packages use to build cross-built emdebian packages.
>  emdebian-tools defaults to taking those packages from unstable, (as in
>  normal Debian uploads). If you want to build against testing or
>  stable instead, then change this setting.

Excellent, thanks. I'll use that one.

-- 

Neil Williams
=============
http://www.data-freedom.org/
http://www.nosoftwarepatents.com/
http://www.linux.codehelp.co.uk/

Attachment: pgp1NWnSgXhvl.pgp
Description: PGP signature


Reply to: