[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dpkg-cross 1.99+2.0.0pre1 refactoring



On Tue, 14 Aug 2007 14:28:16 +0100
Neil Williams <codehelp@debian.org> wrote:

OK, I've tested the dpkg-cross package and it installs successfully
(including the same diversions) still wouldn't recommend using it on a
live system yet (especially as installing it will break apt-cross and
emdebian-tools because of the move to a perl module from dpkg-cross.pl)

apt-cross 0.3.0 and emdebian-tools 0.4.0 will be released at the same
time and depend on dpkg-cross >= 2.0.0 (or libdebian-dpkgcross-perl >=
2.0.0) to solve this. SVN versions of apt-cross and emdebian-tools will
be adapted to work with the dpkg-cross pre-release later this week.

I'll probably make the NorthernCross code in apt-cross >= 0.3.0 into
either Apt::Cross or Debian::AptCross - not sure which and then into a
separate package: libdebian-aptcross-perl to complement the new
libdebian-dpkgcross-perl then emdebian-tools only needs to depend on
the modules, not the binaries (maybe).

> 4. to convert the comments into POD format to generate new man 3
> documentation using pod2man

Works but needs cleaning up.

Right now I'm trying to get the old code into line with 'use strict' so
CVS will be broken for a while whilst that is fixed.

-- 


Neil Williams
=============
http://www.data-freedom.org/
http://www.nosoftwarepatents.com/
http://www.linux.codehelp.co.uk/

Attachment: pgpUNQDmLt79j.pgp
Description: PGP signature


Reply to: