[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [Pkg-emacsen-addons] magit-svn-el packaging



Hello,

Sean Whitton writes:

> Hello,
>
> On Fri, Apr 08, 2016 at 01:53:52PM +0200, Alberto Luaces wrote:
>> Yes, that is my intention, too.  I have joined the team, I verified that
>> I can clone some other repositories, but I have no clue how to start my
>> own.  How is it done?
>
> ssh alioth.debian.org
> cd /git/pkg-emacsen/pkg
> ./init-repo.sh magit-svn
>

Done.

>
>> >
>> > - Could you explain your reason for adding 0001-elpa-version.patch,
>> >   please?  I don't think you need it.
>> >
>> 
>> I got some errors because the absence of a version number in the elpa
>> fields, but I will try again to see if it is not needed currently.
>
> Okay.  Please share the errors so we can help you.

Here is what I get:

--8<---------------cut here---------------start------------->8---
dh_elpa -O--parallel
dh_elpa: emacs -batch -Q -l package --eval (add-to-list 'package-directory-list "/usr/share/emacs/site-lisp/elpa") --eval (add-to-list 'package-directory-list "/usr/share/emacs/site-lisp/elpa-src") -f package-initialize -l dh-elpa.el -f dhelpa-batch-install-file debian/elpa-magit-svn//usr/share/emacs/site-lisp/elpa-src magit-svn.el /build/magit-svn-2.1.1/debian/.debhelper/elpa 1457045045 returned exit code 255
Package lacks a "Version" or "Package-Version" header
debian/rules:4: recipe for target 'binary' failed
make: *** [binary] Error 255
--8<---------------cut here---------------end--------------->8---

Regards,

Alberto


Reply to: