[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Question about installing Debian 8.0.3 arm64 on EUFI



Hi Leif,

I did some more testig with the Debian Testing image of 14-Mar-2016:

1) The xgene_enet ethernet driver does not seem to work properly when
compiled as module. My X-Gene 1 system is not able to get an IP
address from DHCP. In order to fix, I rebuild the 4.4.6 kernel and
changed Device Drivers > Serial ATA and Parallel ATA drivers (libata)
> APM X-Gene 6.0Gbps AHCI SATA host controller support = Y. After
installing the new kernel and restart, the network connected properly
(IP address acquired, apt-get update && apt-get upgrade working).
Kernel config file: http://pastebin.com/i2cPsvH0

2) The Grub installation step in Debian Installer failed on TianoCore
UEFI firmware. The /target/boot/efi directory is empty and the
following error is displayed:

GRUB installation failed
The 'grub-efi-arm64' package failed to install into /target/

Using Linaro's Mini ISO I was able to successfully install Grub. So I
leveraged that to boot Debian Testing.

3) No output is displayed on the embedded graphics adapter. So have to
specify console=ttyS0,115200 for both installer and running Debian and
use serial console. I can honostly live with that, but like to let you
know

4) Fortunately Debian Testing does not corrupt BTRFS like what I
experienced after installing Linaro's Mini ISO. btrfs scrub returns
zero errors after copying more than 800 GB of data. I will create a
separate bug report for Linaro.

Kind regards,
Ronald

On Wed, Mar 16, 2016 at 3:52 AM, Leif Lindholm <leif.lindholm@linaro.org> wrote:
> On Tue, Mar 15, 2016 at 08:06:17PM -0700, Ronald Maas wrote:
>> > Did you also follow the advise stated at the bottom of that post?:
>> > ---
>> > Note: A few people have pointed out that the Gigabyte isn’t SBSA
>> > compliant because it lacks the right serial port, RTC and WDT. However
>> > it still boots RHELSA fine if you add console=ttyS0,115200.
>> > ---
>> >
>>
>> > If not, break into grub and edit the command line by typing 'c', and
>> > add the suggested modification before the --- on the "linux" line.
>>
>> I tried several options, but unfortunately non of these had any effect:
>> console=ttyS0,115200 BOOT_DEBUG=2 DEBIAN_FRONT_END=text acpi=off
>>
>>
>> > There are a couple of reasons why the console might not be picked up
>> > automatically - I am not sufficiently familiar with the Gigabyte
>> > platform to tell which it is.
>> >
>>
>> I ran the Centos installer, and noticed their EFI stub displayed 2 more
>> lines compared to Debian's version:
>>
>> EFI stub: Booting Linux Kernel...
>> EFI stub: Using DTB from configuration table      <-----
>> EFI stub: Existing boot services and installing virtual address map...
>
> Yeah, these two lines only went into 3.16 kernel, and I don't think
> they were cherry-picked into the Jessie kernel.
>
>> <------
>> L3c Cache: 8MB
>>
>> Not sure if this is helpful or not
>>
>> Anyway. Thanks for the suggestions. Ronald
>
> I'm guessing there is something required to boot on the Gigabyte which
> is not yet supported on the Jessie 3.16 kernel.
>
> It would be interesting, but not vital, if you could try again, adding
> "earlycon" to the kernel command line. Won't help anything, but would
> potentially let me know what's going on.
>
> What might help would be trying a newer installer, like the current
> "testing" image:
> http://cdimage.debian.org/cdimage/weekly-builds/arm64/iso-cd/
>
> Or failing that, the mini.iso from
> https://builds.96boards.org/releases/reference-platform/components/debian-installer/16.03/
> is basically a "testing" installer with some added not-yet-upstream
> patches for GRUB/kernel. If the "testing" doesn't work, I would be
> quite interested in seeing if this one helps.
>
> Regards,
>
> Leif


Reply to: