[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#719624: Upgrading xrdp

On Thu, Apr 28, 2016 at 07:09:37PM +0200, Dominik George wrote:
> > I definitely needed to install xorgxrdp as well to get my normal desktop
> > as usual.  While on normal apt-get installs Recommends are installed I
> > wonder what alternative could bring up a sensible desktop otherwise and
> > what a user needs to to to activate this.  If there is no such
> > alternative its probably better to use Depends: xorgxrdp rather than
> > Recommends.
> Well, you could still use VNC by selecting the VNC session from the session 
> selector in the login screen.

Ahhh, that's OK, thought.
> I figure that packages can assume that Recommends are installed when choosing 
> their default behaviour and that someone who disables Install-Recommends knows 
> that they might want to align configuration accordingly.

> However, if you think that the default configuration should work even without 
> Install-Recommends, we can also make xorgxrdp a dependency.

No, forget my comment.

> > One I've got the desktop connection I tested the keyboard in a normal
> > xterm.  What should I say: No special German characters, other keys are
> > quite unexpected.  I somehow feel back in the time where we were
> > desperately seeking a remote connection technique that has all the keys
> > printed on a German keyboard right on the remote computer.  Any idea
> > how this could be fixed?
> We actually saw that with a single Microsoft Remote Desktop client version, I 
> think the one from Windows 7.

Well, yes - that's the case here and this is no subject to change for
the next year(s).

> Windows Vista and Windows 8 worked flawlessly It 
> also seemed to be connected to a GNOME bug because it didn't happen with other 
> desktops. *However*, this also happened with the old xrdp.

In the setup we are currently using Jessie xrdp did a sensible job
compared to all alternatives we tried.
> Could you please try what happens when you force de layout on the server by 
> executing „setxkbmap de“ once after login?

Cool.  This works nicely even with @| etc, where you need AltGr.
> I think we will be able to fix this issue.

Sound promissing after  "setxkbmap de"  seems to fix the issue.
> > I also forced on the stable (Jessie) machine the actual Jessie version via
> > 
> > $ sudo apt-get install xrdp=0.6.1-2
> > 
> > and than tried
> > 
> > $ LC_ALL=C sudo dpkg -i xrdp_0.9.0~20150902+gitc0ef543-1_amd64.deb
> > $ LC_ALL=C sudo dpkg -i xrdp_0.9.0~20150902+gitc0ef543-1_amd64.deb
> > (Reading database ... 357723 files and directories currently installed.)
> > Preparing to unpack xrdp_0.9.0~20150902+gitc0ef543-1_amd64.deb ...
> > Unpacking xrdp (0.9.0~20150902+gitc0ef543-1) over
> > (0.9.0~20150902+gitc0ef543-1) ... Setting up xrdp
> > (0.9.0~20150902+gitc0ef543-1) ...
> > E: /var/run/xrdp has wrong permissions
> > invoke-rc.d: initscript xrdp, action "start" failed.
> > dpkg: error processing package xrdp (--install):
> >  subprocess installed post-installation script returned error exit status 1
> > Processing triggers for libc-bin (2.19-18+deb8u4) ...
> > Processing triggers for man-db ( ...
> > Processing triggers for systemd (215-17+deb8u4) ...
> > Errors were encountered while processing:
> >  xrdp
> That would mean the upgrade path is broken. That's strange because we actually 
> upgraded from the old package to our new one on jessie.
> Did you install 0.9.0 before installing 0.6.2, i.e. did you downgrade in the 
> first place?

Yes, that's what actually happened.  I did not tried a "clean upgrade".

Should I purge everything and try the clean 0.6.2 -> 0.9.0 upgrade just
for verification?

Kind regards



Reply to: