[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#719624: Upgrading xrdp


> My first attempt to connect from a windows machine to my test linux box
> just brings up a ligthblue empty space (same color as xrdp login screen)
> but no window manager or desktop environment (I'm using xfce by
> default).
> I definitely needed to install xorgxrdp as well to get my normal desktop
> as usual.  While on normal apt-get installs Recommends are installed I
> wonder what alternative could bring up a sensible desktop otherwise and
> what a user needs to to to activate this.  If there is no such
> alternative its probably better to use Depends: xorgxrdp rather than
> Recommends.

Well, you could still use VNC by selecting the VNC session from the session 
selector in the login screen.

I figure that packages can assume that Recommends are installed when choosing 
their default behaviour and that someone who disables Install-Recommends knows 
that they might want to align configuration accordingly.

However, if you think that the default configuration should work even without 
Install-Recommends, we can also make xorgxrdp a dependency.

> One I've got the desktop connection I tested the keyboard in a normal
> xterm.  What should I say: No special German characters, other keys are
> quite unexpected.  I somehow feel back in the time where we were
> desperately seeking a remote connection technique that has all the keys
> printed on a German keyboard right on the remote computer.  Any idea
> how this could be fixed?

We actually saw that with a single Microsoft Remote Desktop client version, I 
think the one from Windows 7. Windows Vista and Windows 8 worked flawlessly It 
also seemed to be connected to a GNOME bug because it didn't happen with other 
desktops. *However*, this also happened with the old xrdp.

Could you please try what happens when you force de layout on the server by 
executing „setxkbmap de“ once after login?

I think we will be able to fix this issue.

> I also forced on the stable (Jessie) machine the actual Jessie version via
> $ sudo apt-get install xrdp=0.6.1-2
> and than tried
> $ LC_ALL=C sudo dpkg -i xrdp_0.9.0~20150902+gitc0ef543-1_amd64.deb
> $ LC_ALL=C sudo dpkg -i xrdp_0.9.0~20150902+gitc0ef543-1_amd64.deb
> (Reading database ... 357723 files and directories currently installed.)
> Preparing to unpack xrdp_0.9.0~20150902+gitc0ef543-1_amd64.deb ...
> Unpacking xrdp (0.9.0~20150902+gitc0ef543-1) over
> (0.9.0~20150902+gitc0ef543-1) ... Setting up xrdp
> (0.9.0~20150902+gitc0ef543-1) ...
> E: /var/run/xrdp has wrong permissions
> invoke-rc.d: initscript xrdp, action "start" failed.
> dpkg: error processing package xrdp (--install):
>  subprocess installed post-installation script returned error exit status 1
> Processing triggers for libc-bin (2.19-18+deb8u4) ...
> Processing triggers for man-db ( ...
> Processing triggers for systemd (215-17+deb8u4) ...
> Errors were encountered while processing:
>  xrdp

That would mean the upgrade path is broken. That's strange because we actually 
upgraded from the old package to our new one on jessie.

Did you install 0.9.0 before installing 0.6.2, i.e. did you downgrade in the 
first place?


PGP-Fingerprint: 3C9D 54A4 7575 C026 FB17  FD26 B79A 3C16 A0C4 F296

Dominik George · Mobil: +49-151-61623918

Teckids e.V. · FrOSCon e.V. · OpenRheinRuhr e.V.
Fellowship of the FSFE · Piratenpartei Deutschland
Opencaching Deutschland e.V. · Debian Contributor

LPIC-3 Linux Enterprise Professional (Security)

Reply to: