[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem installing lenny

[Valerio Pachera]
> Before I tried to install for the first time debian edu lenny.
> I selected the first boot option "Install" and proceeded selectin the
> "Main" "Thin C. S" and "workstation" profiles.

It is probably a good idea to skip thin client server unless you plan
to work on fixing the installation.

> I flet lost when it asked the name of OCS inventory machine.
> I wrote "localhost"...

Good choice.  The OCS stuff is not ready yet, and I dropped it from
the default installation yesterday.

> I do not know what is this service...can you give me a short explanation?

It is an web based inventory database.  See 

> After it asked more question about OCS: it asked passwords.
> I inserted the same password of root but it gave me this error:
> "Error 2002 (HY000): can't connect to local mysql server through
> socket '/var/run/mysql/mysql.sock'
> After that I had to select 'ignore' to proceed with the installation.

Yes, this is the problem that need to be solved before we can install
and configure it automatically.

> The next step was "Build LTSP chroot" but there it stopped with an
> error simply saing that the step has failed and that I coulded go
> back to the menù or try again.

I believe this is slightly better now, but the LTSP installation is
currently not tested and probably do not work yet.

> I run the DVD again to use the rescue option thinking it to give me a
> shell bash but it seems to make a new installation !?
> What is rescue mode ment to do exactly?

Have not tested the rescue boot, no idea how it work.

> I have to wait and find a live cd to recover the bootloader on the MBR :)
> The iso I'm using is old of 2-3 days about.

Some of the issues you report are fixed (ocsinventory is no longer
installed), but others (LTSP install) is probably still there.  I have
tested main-server install and main-server + workstation install, and
am working on the PXE installation from main-server at the moment.  I
hope someone can look at the LTSP installation soon.

Note that there is something strange with the automatic configuration
system.  It does not work when I tested in in qemu, but work when I
run it manually during or after installation.  No idea what is going
on.  It will affect several services.

Happy hacking,
Petter Reinholdtsen

Reply to: