[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem with new install

On Thu, 10 Jul 2008 13:18:33 +0200, Frederik <borg.frederik@gmail.com> wrote:

Frederik wrote:
Hi group,
I'm new to Skolelinux and not exactly experienced in the linux world as such. My networking skills are very limited, so i hope you'll all bear with me.
 I have downloaded debian-edu-etch-i386-netinst-3.0r1.iso
I have a HP G4 server with to NICs.
During install i hooked nic 1 up to my home router wich runs dhcp and deals out addresses in the 192.168.1.x range. All worked smooth. I choose the Server, Workstation (Client?), and Thin Client profiles during setup. Using a different computer i changed my router to have ip and NOT provide dhcp, since dhcp will now be provided by the server.
 I can now PXE boot on nic2 (eth1 i presume) which is great.
I can access home drive, server web pages, run various programs on both pxe client and server.
 I cannot, however, access the internet i any way.
 My questions are:
- What should i do?
- Could i use the server on the 10.0.2.x network via nic1 (static ip but dhcp running on router) while dealing out 192.168.1.x addresses to my thin clients on nic2?
- How can i isolate the problem? (dhcp? netmask? squid?)
I hope someone out there will help - this would make a lot of kids happy :)
 /Frederik (from Denmark)

Thanks for your input.
I did a fresh install using only the server and thin-client server profiles.
Everything works now :)

How wonderful!

There are a number of unanswered questions, but the most pressing one is: how hoes the server do DNS? (again, excuse my lack of knowledge) I have at no step indicated the address of my ISP's DNS server.

Will i need to change anything if i move the server to a new location (from:basement, to:school) and a new ISP?

Thanks, :)

As long as your router has and there is no other dhcp server on your network, you should be home free. The (router or firewall) should use whatever settings you isp requires on the outside, and use and no dhcp on the inside.


Reply to: