[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ldap merge test (was: ldap/lwat test)

Bjarne Nielsen skrev:
> Don't know if it's all my fault, or if something is wrong with lwat(?)
> It might as well be me doing something wrong, but here's what I have
> done in case it interests someone:

Please don't blaim lwat, when there might be something wrong with your
ldap setup. I would guess that it's all your fault.

> Running DebianEdu 3.0. I have downloaded lwat from etch-test. I try to
> add an ldif file with some users from a school using Skolelinux2.0.
> First I moved everything from /var/lib/ldap/, then I tried to add the
> ldif-file

There is no tool in lwat to add an ldif. Someone might write one if
there are requests (as in wishlist bugs against lwat in Debian BTS). It
all depends on the time availible, and if it's paid work or not. but if
the ldiff is working it should be no problem adding it using the
command-line tool ldapadd (if slapd is running, and is healty), or with
slapadd (if slapd is not running and the ldif holds all necesarry
information, or will fit together with the existing information in the
ldap db). But the configuration file for ldap needs to be sane.

>  tjener:~# slapadd -l ldifbackup.ldif
>  /etc/ldap/slapd.conf: line 95: rootdn is always granted unlimited
> privileges.
>  /etc/ldap/slapd.conf: line 101: rootdn is always granted unlimited
> privileges.
>  bdb_db_open: Warning - No DB_CONFIG file found in directory
> /var/lib/ldap: (2)
>  Expect poor performance for suffix dc=skole,dc=skolelinux,dc=no

Those are all warnings, but should not maked slapd fail.

> When I restart slapd, no users are found, except system users.

How did you search for users ?

> I tried to add the config file manually, and add ldif again. No change.

Looks like you're doing things wrong then. But SO far I have not seen
you use lwat for anything.

Make sure your configuration is healthy, and is working.
try poining your browser to https://<server>/lwat/setup.php and see if
there is anything sane information on that page..

> Since I don't know any better, I ran ldap-debian-edu-install, and then
> added the ldif file. Running slappadd -c -l ldifbackup.ldif adds all
> users, but then of course no users are member of teachers or students
> group. Otherwise users work, and I can log in.

They should have been if you did things correctly.

> I moved everything from ldap again, put back the original ldap-base, and
> removed the groups students and teachers using lwat. Then I added the
> ldif file. Now everything seems fine, users are in right groups,
> everyone can log in and out. But now I can no longer add users with lwat.


> Here is the error-message I get:
> Warning: ldap_add() [function.ldap-add]: Add: Internal (implementation
> specific) error in /usr/share/lwat/web/functions.php on line 625

It looks like there is a configuration error for your ldap, but it's
hard to say.

OK, lets explain how the priority is done when developing lwat:

1) First priority is always paying custommers, but we try to put aside
time to work on Free Software like lwat, slbackup(-php), other debian
and debian-edu stuff.
2)  Our own (or our paying custommers) wishlist bugs.
3) Security bugs.
4) Functionality bugs reported through Debian BTS
5) Wishlist bugs reported through Debian BTS
6) Functionality bugs reported through DebianEdu/Skolelinux bugzilla

We might take a note of good wishlist bugs from DebianEdu/Skolelinux,
but we tend to forget about them.

So if you really like to improve lwat, or waiting for the "killer
feature", you should contact us with an offer to pay for the development
of lwat.

Finn-Arne Johansen
faj@bzz.no http://bzz.no/
EE2A71C6403A3D191FCDC043006F1215062E6642 062E6642

Reply to: