[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

ldap/lwat test

Don't know if it's all my fault, or if something is wrong with lwat(?) It might as well be me doing something wrong, but here's what I have done in case it interests someone:

Running DebianEdu 3.0. I have downloaded lwat from etch-test. I try to add an ldif file with some users from a school using Skolelinux2.0. First I moved everything from /var/lib/ldap/, then I tried to add the ldif-file

 tjener:~# slapadd -l ldifbackup.ldif
/etc/ldap/slapd.conf: line 95: rootdn is always granted unlimited privileges. /etc/ldap/slapd.conf: line 101: rootdn is always granted unlimited privileges. bdb_db_open: Warning - No DB_CONFIG file found in directory /var/lib/ldap: (2)
 Expect poor performance for suffix dc=skole,dc=skolelinux,dc=no.

When I restart slapd, no users are found, except system users.

I tried to add the config file manually, and add ldif again. No change.

Since I don't know any better, I ran ldap-debian-edu-install, and then added the ldif file. Running slappadd -c -l ldifbackup.ldif adds all users, but then of course no users are member of teachers or students group. Otherwise users work, and I can log in.

I moved everything from ldap again, put back the original ldap-base, and removed the groups students and teachers using lwat. Then I added the ldif file. Now everything seems fine, users are in right groups, everyone can log in and out. But now I can no longer add users with lwat.

Here is the error-message I get:

Warning: ldap_add() [function.ldap-add]: Add: Internal (implementation specific) error in /usr/share/lwat/web/functions.php on line 625

    [dn] => uid=nyler,ou=People,dc=skole,dc=skolelinux,dc=no
    [uidNumber] => 10016
    [gidNumber] => 10016
    [uid] => nyler
    [cn] => ny lærer
    [userPassword] => {SSHA}C2M+ttTYqyiBOVsRvtqVQixwNM42MTM0
    [objectClass] => Array
            [0] => top
            [1] => posixAccount
            [2] => shadowAccount
            [3] => imapUser
            [4] => sambaSamAccount

    [homeDirectory] => /skole/tjener/home0/nyler
    [loginShell] => /bin/bash
    [mailMessageStore] => /var/lib/maildirs/nyler
    [sambaSID] => S-1-5-21-91783970-3244811265-3322612592-21032
    [sambaAcctFlags] => [U          ]
    [sambaLMPassword] => 2919E970ADE5C997C2265B23734E0DAC
    [sambaNTPassword] => 8A8A8232245EB73AE5B4C96A945D204E

I will keep doing other stupid things with lwat/ldap, if no-one like me to post "reports" like this, just tell...

Reply to: