[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: somebody interested in packaging notepadqq ?

at bottom :-

On 3/13/14, RAVI DESAI <ravidesai22@gmail.com> wrote:
> Hi Shirish,
> Thanks for your detailed and to the point guidance.
> I've started with migration to debian sid (testing) from the Wheezey
> stable, but due to power interruption between the installation process,
> somehow I crashed the system. Now I am getting "Oh no! Something has gone
> wrong. A problem has occurred and the system can't recover. Please log out
> and try again.". I am trying to restore my system using rescue mode / using
> shell.
> I have downloaded the packaging-tutorial on another system. I will update
> you the process once I am able to restore the system.
> Thanks,
> Ravi

Dear Ravi,
Please use the mailing list as others would be welcome to chime their
solutions in there as well. I am about to crash on my bed so please
excuse if some things do not make sense.

One of the things I do while doing a dist-upgrade is to have both
apt-listbugs and apt-listchanges installed before making the $sudo
aptitude safe-upgrade

The second thing I do is not to do all the changes at one go but to go
peice-meal. I would share what I mean.

1. Changing sources

a. my older sources (giving just as an e.g. not using all the sources)

deb http://debian.org/debian/ wheezy main contrib

b. my newer sources

deb http://debian.org/debian/ testing main contrib

2. Updating my index

a. I use aptitude so :-

$ sudo aptitude safe-upgrade

(some people use dist-upgrade but I have found out that to be risky or
to do it via a tty terminal).

Let's say it says 500/1000 odd packages need to be updated.

3. Now I know I don't either have the bandwidth to download and
upgrade 500/1000 packages at one go.

the best way is then to take the list of all the 500-1000 packages and
take a bunch of 20-30 packages and download and install them . It's a
trial and error method as it's new to you, the idea is to upgrade
packages in-place and have not too many library transitions happening
at once which is what normally happens in our day-to-day life.

LOL. I was looking at something else and the following note caught my
eye on my system. The note had a list of some of the things once I was

$ sudo aptitude dist-upgrade
[sudo] password for shirish:
The following NEW packages will be installed:
  libboost-date-time1.46-dev{ab} libboost-date-time1.46.1{a}
  libboost-serialization1.46-dev{ab} libboost-serialization1.46.1{a}
  libboost-thread1.46-dev{ab} libboost-thread1.46.1{a} libboost1.46-dev{ab}
  libdrm-nouveau1a{ab} libtirpc1{a} linux-image-2.6.38-2-amd64{a}
  plymouth-drm{a} rpcbind{ab}
The following packages will be upgraded:
  gstreamer0.10-ffmpeg{b} gstreamer0.10-tools hpijs hplip{b} hplip-cups
  hplip-data keyboard-configuration libboost-date-time-dev
  libboost-thread-dev libgl1-mesa-dri libgpod-common libhpmud0
  libimobiledevice1 libsane-hpaio linux-image-2.6-amd64 nfs-common
  openssh-client plymouth-themes-fade-in plymouth-themes-glow
  plymouth-themes-script plymouth-themes-solar plymouth-themes-spinfinity
  xorg xserver-xorg xserver-xorg-core{b} xserver-xorg-input-evdev
  xserver-xorg-input-synaptics xserver-xorg-input-wacom
  xserver-xorg-video-apm xserver-xorg-video-ark xserver-xorg-video-ati
  xserver-xorg-video-chips xserver-xorg-video-cirrus
  xserver-xorg-video-fbdev xserver-xorg-video-i128 xserver-xorg-video-intel
  xserver-xorg-video-mach64 xserver-xorg-video-mga
  xserver-xorg-video-neomagic xserver-xorg-video-nouveau
  xserver-xorg-video-openchrome xserver-xorg-video-r128
  xserver-xorg-video-radeon xserver-xorg-video-rendition
  xserver-xorg-video-s3 xserver-xorg-video-s3virge
  xserver-xorg-video-savage xserver-xorg-video-siliconmotion
  xserver-xorg-video-sis xserver-xorg-video-sisusb xserver-xorg-video-tdfx
  xserver-xorg-video-trident xserver-xorg-video-tseng
  xserver-xorg-video-vesa xserver-xorg-video-vmware
56 packages upgraded, 12 newly installed, 0 to remove and 0 not upgraded.
Need to get 58.6 MB/74.9 MB of archives. After unpacking 174 MB will be used.
The following packages have unmet dependencies:
  libboost-thread1.46-dev: Conflicts: libboost-thread1.42-dev but
1.42.0-4 is installed.
  xserver-xorg-core: Breaks: xserver-xorg-video-6 which is a virtual package.
  hplip: Depends: libsane-hpaio (= 3.11.1-2) but 3.11.1-2+b1 is to be installed.
  libboost-date-time1.46-dev: Conflicts: libboost-date-time1.42-dev
but 1.42.0-4 is installed.
  gstreamer0.10-ffmpeg: Depends: libavcodec52 (< 5:0) but
5:0.6.1+svn20101128-0.2 is installed. or
                                 libavcodec-extra-52 (< 5:0) which is
a virtual package.
  libboost1.46-dev: Conflicts: libboost1.42-dev but 1.42.0-4 is installed.
  libdrm-nouveau1a: Conflicts: libdrm-nouveau1 but 2.4.21-1~squeeze3
is installed.
  xserver-xorg-video-nv: Depends: xorg-video-abi-6.0 which is a virtual package.
  rpcbind: Conflicts: portmap but 6.0.0-3 is installed.
  libboost-serialization1.46-dev: Conflicts:
libboost-serialization1.42-dev but 1.42.0-4 is installed.
The following actions will resolve these dependencies:

      Remove the following packages:
1)      gnome
2)      gstreamer0.10-ffmpeg
3)      hplip
4)      libboost-date-time-dev
5)      libboost-thread-dev
6)      libdrm-nouveau1
7)      libogre-dev
8)      nfs-common
9)      xserver-xorg-video-nv

      Keep the following packages at their current version:
10)     libboost-date-time1.46-dev [Not Installed]
11)     libboost-serialization1.46-dev [Not Installed]
12)     libboost-thread1.46-dev [Not Installed]
13)     libboost1.46-dev [Not Installed]
14)     rpcbind [Not Installed]

      Leave the following dependencies unresolved:
15)     gnash-common recommends gstreamer0.10-ffmpeg
16)     libsane-hpaio recommends hplip (= 3.11.1-2+b1)
17)     totem recommends gstreamer0.10-ffmpeg

Now this is actually at the end of the upgrade when few important
transitions are going to be taking place.

You have to be very aware of the conflicts (if any), be aware of all
the packages that might be removed and try to figure out if they
actually need to be removed.  I make sure any conflicting packages are
not installed in the first go.

The first packages are always those which don't have any conflict and
seem to be easy and install them.

The other thing I do is go /etc/dpkg/dpkg.cfg

and write 'debug=1' as one of the options (without the atostrophe and
any hash).

and upgrade the packages by saying for e.g. :-

$sudo aptitude install keyboard-configuration (from the above list,
this one and couple of others were not complex choices).

For the complex ones, you have to take the whole bunch of them and try
and see if they can be installed. If a removal is asked, read the
changelog to see if the removal is justified or not.

In your case, it's much more simpler, just go to a TTY terminal
(CTRL+ALT+number) and just start doing :-

a. sudo aptitude safe-upgrade -y and after taking the list, install
the ones which are non-threatening.

Try to use GNOME or whichever GUI you are using by saying :-

$ sudo /etc/init.d/gdm3 restart .

At some point, you should start getting the new GUI.

Brokenness in Debian is pretty much a relative word. I have been able
to survive kernel removals, grub issues etc.

You would need to be patient.

It takes me couple of weeks to a month to move from a stable version
to testing/sid as I always prefer to use the safe-upgrade path and
ask,cajole DD's and DM's if there are some removals which are not
located in changelog.gz

It takes time to settle down but eventually it does. The important
thing to do is not to panic and take one $sudo aptitude safe-upgrade
at a time.

At some point in the future you should get there.

If there are any serious or important bugs which apt-listbugs tells
you, don't install or upgrade that particular package/s and wait for
the next minor or major version which doesn't have that particular bug
anymore and then upgrade to that version.

There is another tool called 'apt-show-versions' which also helps in
upgrading and understanding which packages are needed in order to
further an upgrade. An e.g.

 $ apt-show-versions -a gnome-control-center
gnome-control-center:amd64 1:3.8.3-4 install ok installed
gnome-control-center:amd64 1:3.8.3-4   testing      debian.ec.as6453.net
No testing-updates version
gnome-control-center:amd64 1:3.8.3-4   unstable     debian.ec.as6453.net
gnome-control-center:amd64 1:3.11.91-1 experimental debian.ec.as6453.net
gnome-control-center:amd64/testing 1:3.8.3-4 uptodate

Now if I want to install the specific version from exp. (not
recommended at all) is to do something like this :-

$sudo aptitude install gnome-control-center=1:3.11.91-1

In the above e.g. it will not work because the other dependencies
which are needed for the version in experimental to work have not yet
come in as of date.

Sorry for the longish reply. I am sure I have made a mistake or two
while replying.

Till l8er.
          Shirish Agarwal  शिरीष अग्रवाल
  My quotes in this email licensed under CC 3.0
065C 6D79 A68C E7EA 52B3  8D70 950D 53FB 729A 8B17

Reply to: