[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Surprise trying to upgrade(just testing) from Backports.

I run Etch.Below I tried to upgrade(just testing) a simple package(only 5 dependencies) from Debian-Backports
(etch-backports) and surprisingly I got all that,included the upgrade of libc6(!!!),were those backports for
Etch really compiled with libraries of testing,or so? In fact,when I run the command below for testing,
(apt-get -t testing install aide) the difference is really small(only 0.8Mb to 1.xMB of difference in
Need to get...and After unpacking xx.xMB ...).
When I run: apt-get install aide only 2MB of download(4 or 5 packages) and it is done(I have in apt.conf
Etch as the default distribution).I suspect if I do dpkg install aide...,with the backports package all would be better.

mycomputer:~# apt-get -t etch-backports install aide
Reading package lists... Done
Building dependency tree... Done
The following extra packages will be installed:
  bsd-mailx cpp cpp-4.2 exim4 exim4-base exim4-config exim4-daemon-light fontconfig-config gcc-4.2-base libart-2.0-2 libc6
  libc6-ppc64 libcairo2 libcupsys2 libexpat1 libfontconfig1 libfreetype6 libgcrypt11 libgnutls26 libgpg-error-dev
  libgpg-error0 libjpeg62 libkeyutils1 libkrb53 liblockfile1 libopencdk10 libpng12-0 libssl0.9.8 libxft2 linux-libc-dev
  locales mailx tzdata zlib1g
Suggested packages:
  cpp-doc gcc-4.2-locales mail-reader eximon4 exim4-doc-html exim4-doc-info libmail-spf-query-perl glibc-doc cupsys-common
  rng-tools gnutls-bin krb5-doc krb5-user
The following packages will be REMOVED:
  build-essential g++ g++-4.1 libart-2.0-dev libc6-dev libcairo2-dev libcupsys2-dev libexpat1-dev libfontconfig1-dev
  libfreetype6-dev libgcrypt11-dev libgl1-mesa-dev libglu1-mesa-dev libgnutls-dev libjpeg62-dev liblzo-dev libmng-dev
  libncurses5-dev libopencdk8-dev libpcap0.8-dev libpng12-dev libpopt-dev libqt3-mt-dev libssl-dev libstdc++6-4.1-dev
  libtiff4-dev libxft-dev linux-kernel-headers zlib1g-dev
The following NEW packages will be installed:
  aide bsd-mailx cpp-4.2 exim4 exim4-base exim4-config exim4-daemon-light gcc-4.2-base libgnutls26 libkeyutils1
  liblockfile1 libopencdk10 linux-libc-dev mailx
The following packages will be upgraded:
  cpp fontconfig-config libart-2.0-2 libc6 libc6-ppc64 libcairo2 libcupsys2 libexpat1 libfontconfig1 libfreetype6
  libgcrypt11 libgpg-error-dev libgpg-error0 libjpeg62 libkrb53 libpng12-0 libssl0.9.8 libxft2 locales tzdata zlib1g
21 upgraded, 14 newly installed, 29 to remove and 350 not upgraded.
Need to get 24.9MB of archives.
After unpacking 47.7MB disk space will be freed.
Do you want to continue [Y/n]? n

Reply to: