[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#237216: dpkg-dev: dpkg-genchanges can't PGP sign anymore

Package: dpkg-dev
Version: 1.10.19
Severity: grave
Tags: sid
Justification: renders package unusable

This is what i get repeatedly when executing dpkg-buildpackage on various 

------- snip -------------
You need a pass phrase to unlock your RSA secret key.
Key for user ID: Paul Seelig <pseelig@debian.org>
1024-bit key, key ID 57137FE5, created 1996/03/26

Enter pass phrase:
Pass phrase is good.  Just a moment....
 dpkg-genchanges: error: syntax error in source control file ../ethiop_0.7-8.dsc at line 31: expected PGP signature, found something else `'
------- snip -------------

Downgrading to dpkg-dev version (at least temporarily) solved
this problem for me. Seems like the fix for #232916 (which never has been a
problem in my environment) actually made things worse...

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (1001, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.4.24
Locale: LANG=C, LC_CTYPE=de_DE

Versions of packages dpkg-dev depends on:
ii  binutils          The GNU assembler, linker and bina
ii  cpio                       2.5-1.1       GNU cpio -- a program to manage ar
ii  make                       3.80-6        The GNU version of the "make" util
ii  patch                      2.5.9-1       Apply a diff file to an original
ii  perl [perl5]               5.8.3-2       Larry Wall's Practical Extraction 
ii  perl-modules               5.8.3-2       Core Perl modules.

-- no debconf information

Reply to: