[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#133050: dpkg package should depend on sysvinit

On Sat, 9 Feb 2002, Ben Collins wrote:

> Nothing should have to depend on an essential package (which sysvinit
> is), and nothing should have a versioned dep on an essential package
> (makes for bad dep loops).

dpkg conflicts with sysvinit less than 2.80.  This means you can't install it
without first upgrading sysvinit.

However, it may be possible that dpkg gets unpacked, but then won't configure,
until sysvinit is installed.  This could cause the error you are seeing.

A depends will not help in this case, so doing what Benc suggests may be the
only way.

Reply to: