[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Help needed with dependencies (please)

On Fri, Oct 22, 1999 at 11:49:35PM +0100, James Troup wrote:
> Jason Gunthorpe <jgg@ualberta.ca> writes:
> > For the record, this is the direct result of a new 'feature' added to the
> > latest potato dpkg. It now checks dependencies of other packages on the
> > package that is being installed.
> Noooooooooooooooo.  Please God, someone remove this.  Now.  The desire
> to fix bugs is all well and good, but not at the expense of a usable
> dpkg :-/

What? You would rather dpkg allow packages be downgraded without warning and
break dependencies that require the newer version? Dpkg has always gone down
the list of deps and checked the deps' deps. This is nothing new. What it does
not is make sure that by upgrading (or downgrading as the case may be) _wont_
break the dependencies aswell. Case in point:

Package foo pre-depends on libc6 2.1.2, libc6 get's downgraded to 2.0.7. Guess what,
the old dpkg will let that happen.


Reply to: