[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Release Notes - review and comments

* Frans Pop (elendil@planet.nl) [061128 18:48]:
> - 2.1.1 debian-volatile now an official service
>   I see that volatile.d.o is still not up. What is the status for that?

The machine will go into hosting probably this week, and we can continue
setting it up after that.

> - 4.4.5 Possible issues during upgrade
>   "Please check also in Issues to be aware of for etch, Chapter 5 about
>    issues explicitly listed there."
>   I don't feel that this comment should be included in this section.
>   Moving it to "4.1 Preparing for the upgrade" seems more logical to me.


> - 4.5 Upgrading your kernel and related packages
>   - There is no explanation _why_ the kernel should be upgraded
>     separately.

I don't know if that is required at all, this time. Except if you run a
2.2 kernel in Sarge.

I tried to make sure all information is covered in this chapter, but
agree some work needs to be put in - I just didn't want to invest too
much there until it is decided whether we merge this section with
another section or not.

> - 5.4 Upgrading from exim 3 to exim4
>   The use of 'exim 3' and exim4 seems inconsistent. I'd suggest using
>   plain 'exim' in the heading and 'exim (version 3.xx)' in the main text.



> diff -u -r1.107 release-notes.en.sgml
> --- release-notes.en.sgml	26 Nov 2006 13:59:01 -0000	1.107
> +++ release-notes.en.sgml	28 Nov 2006 17:47:03 -0000
> +<![ %defaulted-2.4 [
>  	  <p>If you are currently using a kernel from the 2.4 series,
>            the older stable Linux kernel series, you should upgrade to a 2.6
> -          series kernel, as 2.4 is no longer supported in Etch.
> +          series kernel, as 2.4 is no longer supported in %releasename;.
I used Etch here by purpose - we don't want to have this section in the
release notes of Lenny unchanged.
>            If you are currently using a kernel from the 2.2 series, you 
>            must upgrade to (at least) the 2.4 series, better to a 2.6 series
>            kernel prior to upgrading your packages.
>  <!-- TODO: incoporate this part in this section -->
> -          Some issues associated with an upgrade to 2.6 are documented in
> -          (FIXME - the link is partly broken)
> -          <!--
> -          <ref id="upgrade-to-2.6">. --></p>
> +          Some general issues associated with an upgrade to 2.6 are documented
> +          in <ref id="upgrade-to-2.6">.</p>
> +]]>

I don't think we should restrict this information to architectures with
default-2.4-kernels, because we stop supporting 2.2 and 2.4 for all
architectures, so even people with their own 2.4 kernels are affected
(and we used to ship 2.4 on almost all arches).

> +<![ %defaulted-2.4 [
> +          If you are upgrading from a 2.4 kernel to a 2.6 kernel for the
> +          first time, you must use <package/initramfs-tools/. Using
> +          <package/yaird/ will cause linux-image-2.6 installations to
> +          fail if you are running a 2.2 or 2.4 kernel.
> +]]>

Same as above (and should be handled same independend of which way)

>          <sect1><heading>devfs deprecated</heading>
> -          <p>Etch no longer provides support for <prgn>devfs</prgn>.
> +          <p>&releasename; no longer provides support for <prgn>devfs</prgn>.
See above - Lenny won't deprecate support for devfs.

> -          <url id="http://bugs.debian.org/341152"; name="#351152">.
> -          </p>
> +          <url id="http://bugs.debian.org/341152"; name="#351152">.</p>
Why did you do this change? I rather prefer the other style (but that
might be personal preference - and my personal preference is of course
not the important one for the release notes).


Reply to: