Am 19.06.2016 um 23:39 schrieb Santiago Vila: > # apt-get upgrade > [...] > # apt-get dist-upgrade > [...] > E: This installation run will require temporarily removing the essential package sysvinit-utils:amd64 due to a Conflicts/Pre-Depends loop. This is often bad, but if you really want to do it, activate the APT::Force-LoopBreak option. > E: Internal Error, Could not early remove sysvinit-utils:amd64 (2) > > > I can reproduce this on a jessie system with very few packages > installed and this single line in sources.list: > > deb http://httpredir.debian.org/debian stretch main > > > If this problem is the result of fixing this bug, I would rather keep > the bug unfixed and leave things as before. It's not, afaics. My guess is it's related to  I suspect this can be fixed by dropping the Breaks: initscripts (<< 2.88dsf-59.5) from the initscripts package and only keeping the Replaces (I know this is not a 100% policy compliant, but I've seen this approach used before where apt got confused). Regards, Michael  https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=827212 -- Why is it that all of the instruments seeking intelligent life in the universe are pointed away from Earth?
Description: OpenPGP digital signature