[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

re: Compatibility of libs for Berkeley DB (libdb5.1-dev or libdb4.8-dev)

I cannot install libdb4.8-dev + libdb4.8, because it conflicts with libdb5.1.
This does not seem to be true, the dev packages conflict but afaict the libraries themselves (at least the versions from debian squeeze and wheezy) do not. So as long as you don't need libdb5.1-dev installed you should be fine.

If you need to use other dev packages that depend on the db dev packages to build bitcoind then I would suggest building it in a squeeze chroot. Once you have built it it should be easy enough to install required binary libraries on your wheezy system as unlike dev packages they rarely conflict.

Please direct further queries to debian-user.

Reply to: