[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Testers (and Debhelper Perl Developers) needed: Debhelper support for PHP5 and SAPI/module php5 {en,dis}mod helper

[please move the discussing to pkg-php-maint after the initial email,
unfortunatelly the NSA^H^H^HGMail is unable to simply set Reply-To:


I have just commited a couple of patches to php5 git which add:

1. support for selective enabling/disabling module for specific SAPI
(php5enmod -s fpm recode)

2. support for maintainer script/local administrator {en,dis}mod (the
local administrator always overrides the maintainer script) (php5enmod
-m vs php5enmod)

3. dh_php5, dh_phpize and dh_phpize_clean support for debhelper (and I
can build php-apcu with very simple debian/rules script now).

4. new php5query script which can be used to query installed modules
and supported php 5 SAPIs

The changes were lousely modeled (and or copied) after dh_apache2
changes in apache2 2.4 packages.

For more information see our PHP git and 5.5.0+dfsg-7 changelog.

Now I need several things to help with:

a) I can't read nor write perl code without getting dizzy, so dh_
scripts needs some love (f.e. to be able to correctly parse
-O-D<sourcedir>).  Especially the dh_phpize and dh_phpize_clean are
bare minimum.

b) man pages / documentation / etc.

c) testing upgrade paths from sid and from jessie.

d) module maintainers – please try new dh_php5 (dh $@ --with php5) –
you can find an example in php-apcu git – and report success/failures
(preferrably with patches).

Ondřej Surý <ondrej@sury.org>

Reply to: