[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: epoch fix?

Bastian Blank <waldi@debian.org> writes:
> On Wed, May 08, 2013 at 05:30:11AM -0500, Peter Samuelson wrote:
>> One real problem is that epochs make it easier to introduce human
>> error in specifying reverse runtime and build deps.  E.g.:
>>     # in stable
>>     Package: libfoo-dev
>>     Version: 1:1.4.1-1
>>     # in unstable
>>     Package: libfoo-dev
>>     Version: 1:1.5.5-2
>>     # in unstable
>>     Package: bar
>>     Build-Depends: libfoo-dev (>= 1.5)
>> The 'bar' maintainer intended to require the unstable version of
>> libfoo-dev, but in fact the dependency is satisfied from stable as
>> well.
> No real damage done. If it is built against 1:1.4 it will either not
> work or be rejected. Also one must not build stuff for unstable against
> stable anyway.
> Please show a real-world example where this breaks, not only may produce
> slightly undesired results.

There is a real-world outside the buildds.

My first step to get a newer package version for a stable system in the
absence of an official backport is typically apt-get source foo &&
apt-get build-deps foo (with deb-src from unstable), followed by
dpkg-buildpackage. If the first works, but the second fails because of
unsatisfied build dependencies, something is definitely broken.



 »Time flies like an arrow, fruit flies like a Banana.«

  PGP fingerprint: 5B93 61F8 4EA2 E279 ABF6  02CF A9AD B7F8 AE4E 425C

Reply to: