[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: New version of libselinux makes libpcre3 pseudo-essential

2013/5/7 Laurent Bigonville <bigon@debian.org>:
> Hello,
> As Guillem asked me in a bug report (#695620), I'm bringing this to
> debian-devel.
> The latest version of libselinux is now using libpcre3 instead of the
> regex functions from the glibc. This is improving the performances
> quite substantially when relabeling the filesystem.
> The version of libselinux in experimental is already using libpcre3.
> This would probably requires to bump the priority of libpcre3 from
> standard to required.
> What are your thoughts about this?

Does it matter? If libselinux depends on libpcre3, libpcre3 will be pulled.
I believed all libraries are "optional".

Reply to: