[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: debian mate

On Mon, Nov 05, 2012 at 02:57:35AM +0400, Виталий Короневич wrote:
> debian gnome-edition - ok
> debian kde-edition - ok
> debian lxde-edition - ok
> debian xfce-edition - ok

Those aren't really editions comparable to Ubuntu's editions or
Fedora's spins. You just install a regular Debian and choose the
desktop enviroment you want.

> when will debian mate-edition?

This isn't as easy and straight-forward as you might think. There are
many problems that need to be solved with MATE first before it can
enter Debian. Some of these are discussed here [1].

One of the biggest problems with MATE so far is that it currently
depends on libraries and other things that have been deprecated and
removed in Debian and should not be reintroduced to Debian. Thus, the
MATE developers are working to port MATE to more recent libraries
which are available in Debian.

Furthermore, work has to be done to make sure MATE co-installs
seamlessly with anything from GNOME which isn't that trivial. There
are many binaries and libraries which still exist in GNOME3 and
installing MATE could possibily break these.

I'm actually helping the MATE developers to get MATE ready for Debian,
but don't expect that to happen anytime soon.

I'm also working on getting mdm ready, a fork of gdm 2.20. Currently,
I'm not really happy with the code, however.


> [1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=658783

Reply to: