[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: packages with E: md5sum-mismatch in the archive

* Andreas Beckmann <debian@abeckmann.de>, 2012-09-20, 18:52:
Actually, we have lintian errors on the packages in the archive:

E: guile-1.6-libs: md5sum-mismatch usr/lib/libguile-srfi-srfi-4-v-1.la
E: guile-1.6-libs: md5sum-mismatch usr/lib/libguile-srfi-srfi-13-14-v-1.la
E: guile-1.6-libs: md5sum-mismatch usr/lib/libguilereadline-v-12.la
E: guile-1.6-dev: md5sum-mismatch usr/lib/libguile-ltdl.la
E: guile-1.6-dev: md5sum-mismatch usr/lib/libguile.la

I tried rebuilding guile-1.6 in a clean sid pbuilder chroot on amd64 and could not reproduce the error. So a binNMU might be sufficient to fix this.

A binNMU would just paper over the actual bug. guile-1.6 debian/rules has this:

	sed -i "/dependency_libs/ s/'.*'/''/" `find $(CURDIR)/debian/ -name '*.la'`

...which is wrong.

Jakub Wilk

Reply to: