[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

MBF: packages using deprecated GnuTLS functions


I am currently trying to rebuild GnuTLS rdeps against GnuTLS 2.12, this
offers the perfect opportunity for a MBF. ;-)

The newer version of GnuTLS marks a couple of interfaces as
deprecated, i.e. they will be removed in future versions of GnuTLS.
Some of these are used in many packages.

Instead of invoking a couple of functions to set connection parameters
(gnutls_protocol_set_priority gnutls_cipher_set_priority
gnutls_compression_set_priority gnutls_kx_set_priority
gnutls_mac_set_priority etc.) a combined priority string
(gnutls_priority_*) is used. The replacement functions are already
available in squeeze (2.8.6).

The MBF will probably touch about 60 packages, I will submit with
severity normal.

cu andreas
`What a good friend you are to him, Dr. Maturin. His other friends are
so grateful to you.'
`I sew his ears on from time to time, sure'

Reply to: