[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

GPL-licensed software linked against libssl on buildds!


it seems that some buildds occasionally have libssl-dev installed in
their chroot. A friend of mine has found out that the netatalk package
depends on libssl0.9.8 [sparc] in sid and [hppa, mipsel] in squeeze.
Other architectures are not affected. For GPL-licensed software like
netatalk this is IMHO to be considered a license violation and thus RC!

If you have a look at the build logs on e.g. sparc, you will see that
indeed the configure script detects an OpenSSL installation and builds
the package against it:

This doesn't happen on other archs:

I guess the buildds for the affected archs need their chroots cleaned up
and netatalk needs bin-NMUs scheduled, right?


Reply to: