[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Minimal kernel version raised to 2.6.27

On Tue, Nov 10, 2009 at 06:08:08PM +0100, Marco d'Itri wrote:
> Due to changes in udev 147, squeeze will not support kernels earlier
> than 2.6.27.

> If your packages have code needed to support old kernels, this is the
> right time to clean it up.

No, it isn't.  Packages need to support the 2.6.26 kernel from lenny to
ensure smooth upgrades.  udev ought to as well, but if it can't, that's
still not precedent for making other parts of the upgrade path more fragile.

Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
Ubuntu Developer                                    http://www.debian.org/
slangasek@ubuntu.com                                     vorlon@debian.org

Attachment: signature.asc
Description: Digital signature

Reply to: