[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [Pkg-sysvinit-devel] Bug#494001: Minimum kernel requirement for Squeeze

On Fri, 20 Mar 2009, Marco d'Itri wrote:
> On Mar 19, Roger Leigh <rleigh@codelibre.net> wrote:
> > With respect to #494001, I would like to determine the minimum
> > version of the linux kernel we will
> For the new udev package[1] I am trying *very* hard to keep it working
> even with 2.6.18 kernels long enough to be able to finish the upgrade,
> but I can tell you that 2.6.22 is currently required to support
> important features like persistent device names and this will only get
> "worse" with time so next year I may end out requiring 2.6.26 anyway.
> Also expect problems from a modern udev and lenny kernels, because they
> I agree that there should be no version check in the init scripts, just
> symlink mtab and almost everything will work fine.

So be it, then.  Let's switch to the new mode unconditionally... since udev
is going to force our hands, might as well at least get something good out
of it and simplify things on the initscripts end.

A NEWS entry will be required to warn people using older kernels, though.

  "One disk to rule them all, One disk to find them. One disk to bring
  them all and in the darkness grind them. In the Land of Redmond
  where the shadows lie." -- The Silicon Valley Tarot
  Henrique Holschuh

Reply to: