[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: experimental buildds using too much of experimental ?

Mike Hommey wrote:
> Hi,
> I noticed that the autobuilt webkit on amd64 depends on the sqlite
> library package from experimental. This sounds pretty unfortunate, as
> webkit doesn't require a specific version of libsqlite, and would work
> fine with the unstable one. On the other hand, as a user, I would be
> quite disappointed to have to install the experimental sqlite to be able
> to test experimental webkit.

What sqlite package in experimental? AFAICS it uses the one from unstable.

> Anyways, why aren't the experimental buildds using as much unstable
> packages as possible when building packages (like what pbuilder does,
> for instance)?

Isn't it rather the opposite? experimental buildds use packages from
unstable if they could satisfy the direct build dependency while
pbuilder will at least use the version from experimental if using the
version from unstable won't work.



Reply to: