[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Packages still depending on GTK+ 1.2

Le Fri, Dec 05, 2008 at 10:41:52PM +0100, Morten Kjeldgaard a écrit :
> Please don't remove GTK+ 1.2. There are still upstream authors,  
> especially in science who use GTK+ 1.2 and who don't bother revising  
> their programs from the wisdom: if it ain't broke don't fix it.

Hi Morten,

With its thousands of packages, Debian is not so rich in manpower, so if the
current maintainers of GTK+ 1.2 want to abandon it and the QA team is not
interested in keeping it, there is no other choice than to adopt it (and its 43
bugs) if you want it to stay in Debian. It had less than upload per year since
2003, so maybe it is doable. Also, I think that it is possible to opt-out
security support if this an issue (but it might make the package unfit for

In our experience with GAMGI (http://www.gamgi.org/), GTK+ 1.2 was indeed
useful to prepare a preliminary package that helped to convince Upstream to GTK

Have a nice day,

Charles Plessy
Debian Med packaging team,
Tsurumi, Kanagawa, Japan

Reply to: