[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: issues with aptitude dist-upgrade from etch to lenny

On Wed, Aug 13, 2008 at 03:40:15PM +0200, Henning Glawe wrote:

> seems like in the dist-upgrade from etch to lenny is one very annoying (and
> old, AFAIR I hit it already in woody->sarge and sarge->etch) problem: perl is
> in an unusable state during the upgrade and causes maintainer scripts to
> fail.

> after the system working for a while, maintainer scripts started to fail and
> aptitude exited.
> the maintainer-script errors were perl-related: the interpreter could not
> find modules (all from perl-base) in @INC.
> further investigation showed that perl-base was still installed in the
> etch-version, while perl itself was from lenny (and of course, the lenny
> version was not finding its own versioned modules from perl-base).

Thanks for the report. Do you have any logs left? At least
/var/log/dpkg.log and /var/log/aptitude.log would be interesting. Please
file a bug against the perl package with those, and preferably some of
the error messages you got of course.

I haven't seen this kind of breakage myself in test upgrades, and the
issues reported so far have been related to the "Locale::Gettext problem"
(#488300 et al.)

BTW, I think there must be something wrong with your description:
/usr/bin/perl is in perl-base, and it certainly should find the modules
in perl-base itself...
Niko Tyni   ntyni@debian.org

Reply to: