[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Should the X packages pre-depend on awk?

On Sat, 2 Aug 2008, Steve Langasek wrote:

> Santiago, please see
> <http://lists.debian.org/debian-devel/2008/07/msg01028.html> for an
> explanation of why I've reassigned this bug; I think awk has been
> accidentally left outside the Essential set in a subtle way that has gone
> largely unnoticed, probably because no one uses awk in their preinst
> scripts. :)

Thanks a lot for the explanation.

My only fear is: Will debootstrap manage gracefully a base-files
package having a pre-depends: awk?

If yes, would the fix for this (a pre-depends: awk) be allowed in lenny?

Reply to: