[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: gnome 1.x removal

On Tue, 2008-01-15 at 00:07 +0100, Pierre Habouzit wrote:
> Then I'll do some more runs of the same principle on other gnome 1.x
> related libs until we got rid of them al.
> If you know your package depends on gnome 1.x one way or the other, now
> is the time to fix that, package a new upstream, or ask for its removal,
> so that it eases our work.

This happened once before when the issue was gnucash.

I was the gnucash maintainer, and the gnome maintainers had decreed that
"Debian must not have gnome 1.x in it!"  And all the libraries were
about to vanish.

This is not the right process for something like this.  Instead, I
believe you should find out specifically which packages depend on gnome
1.x, and offer those maintainers the option of taking over maintenance.

It is not a trivial task to port many programs to gnome 2; it took
gnucash a long time.  Don't screw over other maintainers; make it easy
for them.

Don't start filing remove requests until other maintainers have a
chance.  Take the step of contacting those who maintain packages that
depend on the libraries you want to remove, post RFAs instead of remove
requests, and only post remove requests after people have had a goodly
chance to take over maintenance themselves.


Reply to: