[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Editing the sources in "debian/rules clean"

Reinhard Tartler <siretart@debian.org> writes:

> Consider the case that you create a patch for a package in unstable on a
> stable system. The autotools-dev package on stable is definitely older
> than in unstable, so you always downgrade your version of config.*.
> This seems to be a rather typical usecase when preparing security
> updates.

It seems rather irrelevant to me, though.  Presumably the config.* files
that shipped with the autotools-dev in stable are sufficient to support
all architectures that released with stable.  As long as that's the case,
why should it matter whether the original source package had newer or
older versions?

If that causes a problem, I suspect a deeper bug elsewhere.

Russ Allbery (rra@debian.org)               <http://www.eyrie.org/~eagle/>

Reply to: