[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: wxwidgets 2.8 needs help !

On Fri, Nov 09, 2007 at 07:51:31PM +0100, Bernd Zeimetz wrote:
> > 
> > So what about that? 2.8 is around since almost 1 year, and this delay
> > is not justifiable IMHO. There are now tons of developers and
> > maintainers that need to build against 2.8, and I doubt a transition
> > plan from 2.6 has sense due to API and behaviors changes. We have
> > simply to cope with two different versions, as already happens 
> > for other libraries.
> I guess ron will happily package 2.8 for you if you fix all the bugs in
> it first. If 2.8 is worse than 2.6 (which crashes here way too often),
> then it doesn't make sense to package it at all.
> Better hope that 3.0 will be better...

Well, I would hope that we don't need to do grunt homework for the
wxwidgets upstream. If developers are so stupid to adopt an unstable
and unusable product for their programs, it is their bad choice
not a problem of us. I see by ubuntu reports that 2.8 has the same
(bad?) quality of 2.6, so what's the point? I still have to see
libraries which lack bugs and programs that do not misuse them
and cause other bugs. The choice of 2.6 instead of 2.8 or the
future 3.0 is definitively a per-program ones, it is not
a duty of the library package.

Also if one is not able to cope with patches and bugs of a specific
library, why not calling for helpers or giving up? Inaction is
not a solution.

Francesco P. Lovergine

Reply to: