[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: conflicting gssapi libraries

On Fri, Aug 10, 2007 at 04:53:32PM +1000, Brian May wrote:
> [4 letter words deleted]

> === cut ===
> # sudo dpkg -i libgssapi2-heimdal_1.0.1-1_i386.deb                                                                                                                                                                                               ──(Fri,Aug10)─┘
> Selecting previously deselected package libgssapi2-heimdal.
> (Reading database ... 188542 files and directories currently installed.)
> Unpacking libgssapi2-heimdal (from libgssapi2-heimdal_1.0.1-1_i386.deb) ...
> dpkg: error processing libgssapi2-heimdal_1.0.1-1_i386.deb (--install):
>  trying to overwrite `/usr/lib/libgssapi.so.2.0.0', which is also in package libgssapi2
> Errors were encountered while processing:
>  libgssapi2-heimdal_1.0.1-1_i386.deb
> === cut ===

> [more 4 letter words deleted]

> This wasn't a problem until just recently because it use to be
> libgssapi.so.1.0.0 in Heimdal.
> Solution?

Persuade Heimdal upstream to provide an soname that uniquely identifies this
library in the face of other, pre-existing libgssapi packages, and barring
that, add a Debian-specific soname component to it?

Or if the libraries are actually fully ABI-compatible, perhaps the two
packages could have the same Provides that could be used in the shlibs?

Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
vorlon@debian.org                                   http://www.debian.org/

Reply to: