[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: APT 0.7 for sid

On 08-Jun-07, 09:40 (CDT), Daniel Burrows <dburrows@debian.org> wrote:
>   Why did it want to remove your packages? I can't think of any reason
> that missing the previous release should have caused problems --
> unless maybe there were broken dependencies that needed the previous
> release in order to be resolved?

There was a time when aptitude preferred to upgrade a package, even
if such an upgrade would cause the removal of 30% of the rest of the
system due to dependency issues. The "obvious" (to a human) solution of
putting the single package on hold until the other packages caught up
was something aptitude couldn't spot.

The "new" dependency resolver, with its scoring and easily overridable
choices, has pretty much solved this problem. But someone burned a few
years ago might not know this.


Steve Greenland
    The irony is that Bill Gates claims to be making a stable operating
    system and Linus Torvalds claims to be trying to take over the
    world.       -- seen on the net

Reply to: