[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Template toolkit: removed functionality issue


I write as someone preparing an NMU for

Template Toolkit 2.15 removed a few plugin modules from the main
distribution and I would like to package this new version.
The plugins removed are:


I've checked packages depending on libtemplate-perl, and the only
package that appears to use any of these plugin modules is bugzilla.
Would it therefore be okay to simply package libtemplate-plugin-gd-perl,
and have bugzilla depend on it (and possibly the equivalent
libtemplate-plugin-dbi-perl and libtemplate-plugin-gd-perl packages),
and then upload a new libtemplate-perl reflecting upstream's changes
with a NEWS.Debian entry explaining the change? Should libtemplate-perl
then Recommend or Depend on the new separate plugin modules? My
intuition would be to avoid a Depends.



Dominic Hargreaves | http://www.larted.org.uk/~dom/
PGP key 5178E2A5 from the.earth.li (keyserver,web,email)

Reply to: