[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: lilypond and python



Le jeu 27 juillet 2006 05:02, Thomas Bushnell BSG a écrit :
> Stephen Gran <sgran@debian.org> writes:
> > What is this, solution number 4 for Mr. BSG's complaints?  I am
> > almost beginning to believe that he is more interested in
> > complaining than just fixing the problem.
>
> Solution?  How about this, if I apply that recipe and try to compile,
> you pay me $100 bucks if it doesn't work out of the box.

  I'm tired of you whining. So I've decided to prove you that you spent 
more time crying/whining that the necessary time to upload a new 
version... And I found that it's worse than what I've ever feared:


 (1) I've taken the 2.8.x upstream tarball and your debian/ dir from the
     old one.

 (2) I've spend 15 minutes checking that the patch against the previous
     package were correctly merged. Then I've tried to build it, got an
     error because it uses a python2.4-ism. 5 minutes googling proved
     that there is a trivial patch to use python2.3 AS UPSTREAM CLAIMS
     ON ITS HOMEPAGE, thing that as a maintainer of that package your
     are supposed to know.

 (3) I've applied that patch (adding [ ] around an expression) and
     recompiled.

     then it fails on the attached error. which is all *but* python
     related. Still, just to be sure, I've forced the use of python2.4
     with dato's patch + {aclocal,autoconf} of the package, and it still
     failed at the same place.


  it seems that guile 1.6.8 is buggy. people reported to have build 
lilypond with guile 1.6.7 and/or guile-1.8 correctly. And I suppose 
*HERE* is the real problem, which you failed to spot, because you 
didn't even TRIED to. I had that problem 1 hour after I started 
(previous steps included, so after roughly 20 minutes of compilation). 

  FYI this is bug #316083 (please package guile-1.8)


  attached (and I'm really way to kind to give you that) is the current 
state of my work. All that mail just proves that you are just lazy, and 
that you prefer to troll instead of doing actual work. I didn't know a 
bit of lilypond packaging before I even started. It took me 1hour to 
have the first real problem, and it was NONE of what you claimed 
that /may/ /possibly/ be a problem.

  What did I proved ? that you were ranting instead of doing a 1hour 
long work and be done ? no worse. I've proved that you have postponed a 
straightforward task, rumbling about python2.4 where it was completely 
irrelevant to the problem, and whereas you are asked to package new 
upstream since /monthes/. So since /monthes/ you could have been aware 
that you needed a new guile. But isntead, you've polluted mails lists 
with noise.
  You've missed the real problem, and because of that, since packaging a 
new guile won't be easy *now* so near before the freeze, your lack of 
work has just lead lilypond to have a very good risk not beeing able to 
make it into etch.

  So now bluff-time is over, ALL the noise you did, and you did a *lot*, 
lied on pure wind and mediocrity. Hence, I will second any formal 
request to the Front Desk to have you redo NM again, like in 
<20060726021835.GA32166@chistera.yi.org>.

-- 
·O·  Pierre Habouzit
··O                                                madcoder@debian.org
OOO                                                http://www.madism.org
/tmp/buildd/lilypond-2.8.4/out/share/lilypond/current/ly/music-functions-init.ly:99:1: error: GUILE signaled an error for the expression beginning here
#
 (use-modules (scm display-lily))invalid module name for use-syntax ((srfi srfi-39))

/tmp/buildd/lilypond-2.8.4/out/share/lilypond/current/ly/music-functions-init.ly:99:5: error: syntax error, unexpected '-', expecting '='
#(use
     -modules (scm display-lily))Backtrace:
In unknown file:
   ?:  0* [lilypond-main ("/tmp/buildd/lilypond-2.8.4/ly/generate-documentation")]
   ?:  1* (letrec ((no-files-handler #)) (if (ly:get-option #) (gui-main files)) ...)
In /tmp/buildd/lilypond-2.8.4/out/share/lilypond/current/scm/lily.scm:
 380:  2  (let ((failed #)) (if (pair? failed) (begin # #) (begin # #)))
 380:  3* [lilypond-all ("/tmp/buildd/lilypond-2.8.4/ly/generate-documentation")]
 398:  4  (let* ((failed #) (handler #)) (for-each (lambda # # # ...) files) failed)
 402:  5* [for-each #<procedure #f #> #]
In /usr/share/guile/1.6/srfi/srfi-1.scm:
 666:  6  (if (null? rest) (letrec ((lp #)) (lp list1)) ...)
    ...
 670:  7  (begin (f (car l)) (lp (cdr l)))
 671:  8* [#<procedure #f #> "/tmp/buildd/lilypond-2.8.4/ly/generate-documentation"]
In /tmp/buildd/lilypond-2.8.4/out/share/lilypond/current/scm/lily.scm:
 404:  9* [lilypond-file #<procedure #f #> ...]
 413: 10  [catch ly-file-failed #<procedure #f ()> #<procedure #f (x . args)>]
In unknown file:
   ?: 11* [#<procedure #f ()>]
In /tmp/buildd/lilypond-2.8.4/out/share/lilypond/current/scm/lily.scm:
 414: 12* [ly:parse-file "/tmp/buildd/lilypond-2.8.4/ly/generate-documentation"]
In /tmp/buildd/lilypond-2.8.4/out/share/lilypond/current/ly/music-functions-init.ly:
  45: 13* (display-lily-init parser)

/tmp/buildd/lilypond-2.8.4/out/share/lilypond/current/ly/music-functions-init.ly:45:56: In expression (display-lily-init parser):
/tmp/buildd/lilypond-2.8.4/out/share/lilypond/current/ly/music-functions-init.ly:45:56: Unbound variable: display-lily-init
make[2]: *** [out/lilypond-internals.texi] Error 2
make[2]: Leaving directory `/tmp/buildd/lilypond-2.8.4/Documentation/user'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/tmp/buildd/lilypond-2.8.4/Documentation'
make: *** [all] Error 2

Attachment: lilypond_2.8.4-0.1.diff.gz
Description: GNU Zip compressed data

Attachment: pgpgNcPk0h515.pgp
Description: PGP signature


Reply to: