[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: lilypond and python

Em Tue, 25 Jul 2006 01:56:26 -0700
Thomas Bushnell BSG <tb@becket.net> escreveu:

> In my opinion, the current lilypond in Debian is not suitable for
> release, even with the existing problems solved.  It would not be
> appropriate to release such an old version in etch, and if nothing
> happens with python by the time etch is released, then lilypond should
> be removed from etch.

I may have missed something on why you can't package it right now, but
current build tools will use python2.4 instead of python to run
setup.py if you declare such a dependency in debian/pyversions, as well
as sed through the runnable files sed'ing the hashbang header, IIRC.

Take a look at some other application which requires python2.4, such as
turbogears and gazpacho, maybe?

That said, I would also like to see python-defaults upgraded to
python2.4, and can't see a reason for much more delay.

See you,

Gustavo Noronha Silva <kov@debian.org>

Reply to: