[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Self-conflicts and self-depends

Il giorno lun, 24/07/2006 alle 23.22 +0200, Jan C. Nordholz ha scritto:
> > unison:
> >   Conflicts on unison (<< 2.9.1-3)
> I guess this is meant to prevent older versions of unison and unison2.9.1
> (which Provides: unison) from being installed together (the same holds
> for unison-gtk).

If unison2.9.1 conflicts with unison and provides unison, that is enough
and there is no need for unison to conflict with himself.

Il giorno lun, 24/07/2006 alle 23.22 +0100, martin f krafft ha scritto: 
> An upgrade is the same as removing the old and installing the new
> package, so other than maintainer script invocations (which will
> differ if the old package was removed because of a conflict),
> I don't see a difference. Of course, dpkg wouldn't let you a package
> if it created a conflict, so yeah... no point...

If nobody disagree, I'll start filing bug reports for the packages
listed in the first email of the thread and I'll bug lintian to add a
check for this case.


Fabio Tranchitella <kobold@debian.org>                        .''`.
Proud Debian GNU/Linux developer, admin and user.            : :'  :
                                                             `. `'`
   http://people.debian.org/~kobold/                           `-
1024D/7F961564, fpr 5465 6E69 E559 6466 BF3D 9F01 2BF8 EE2B 7F96 1564

Attachment: signature.asc
Description: Questa =?ISO-8859-1?Q?=E8?= una parte del messaggio firmata digitalmente

Reply to: