[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Uploading packages built against testing?

Am Montag, 29. Mai 2006 21:16 schrieb Thomas Viehmann:
> Hendrik Sattler wrote:
> > No, but you could manually set all stuff in Depends to the needed
> > versions. That would also work for the buildds, I guess.
> And break at the next opportunity (binNMU, recompile, update in a
> hurry...).

If he knows that his application is satisfied by openssl-0.9.8_0.9.8a-1, why 
would it break? No app in testing breaks because the newer openssl enter 
The automated shared lib dependency calculation surely works but does not 
always give optiomal results, e.g. it will pin to a specific libc (building 
packages of non-free apps is sometimes better done with setting the depends 
Update in a hurry: problem of the maintainer.
binNMU & recompilation: won't break if the app really works with this older 
version and the lib must be ABI-compatible anyway.

Automatism is good but not the only way to do stuff.


Reply to: