[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Lintian package-has-a-duplicate-relation

[Andreas Metzler]
> rocheml@httrack.com wrote:
> > Is there a way to force a specific library version known in
> > ${shlibs:Depends} ?
> Why would you want to do that?

Don't know about the original poster, but here's my reason: I want to
reduce user confusion.  Most of the interesting bits of subversion are
actually in libsvn0, but this is not obvious to users, so if their
subversion and libsvn0 packages are not the same version, they get the
wrong idea about what features and behaviors are available.

It's not strictly _necessary_ for subversion to Depends: libsvn0
(= ${Source-Version}), but I'd like to do it anyway to reduce instances
of non-bugs like #359215.

Attachment: signature.asc
Description: Digital signature

Reply to: