[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Box does not switch of on halt


since about three weeks I observe problems when issuing halt
on three different testing-boxes (two older desktops without ACPI
and one laptop with ACPI).  The computer just does not switch off.
If I try to reboot it is also impossible, because the shutdown
process stops at the same point where halt stops.  The last
messages on the console are:

  Shutdown: hda
  System halted.

At one single time I managed to observe at the console

  Saving random seed ... done
  Usage: grep [OPTION] ... PATTERN [FILE] ...
  Try `grep --help` for more information
  Shutdown: hda
  System halted.
  Unmounting remote and non-toplevel virtual filesystems ... done

The log of one of this machine does not uncover something

Mar  6 22:43:35 energija kernel: nfsd: last server has exited
Mar  6 22:43:35 energija kernel: nfsd: unexporting all filesystems
Mar  6 22:43:35 energija kernel: RPC: failed to contact portmap (errno -5).
Mar  6 22:43:35 energija mountd[1175]: Caught signal 15, un-registering and exiting.
Mar  6 22:43:35 energija kernel: Kernel logging (proc) stopped.
Mar  6 22:43:35 energija kernel: Kernel log daemon terminating.
Mar  6 22:43:35 energija exiting on signal 15

At Linux-Tage Chemnitz I discussed this problem with other

   1. One of them has observed the same (no solution)
   2. One visitor had the same problem. Installing Debians
      own linux kernel image package helped
   3. One hint was to load APM module

Remarks: I tried different kernels (I had originally installed
self-made 2.6.9 / 2.6.11, upgraded to self-made 2.6.15 and even
tried official 2.6.15 kernel image - see item 2.) but the
situation did not changed.  I suspected a change in the apmd
package and tried to downgrade the apmd package on the apmd
machines which also did not helped.

So the question is: what package might be responsible that
entered testing for about three weeks and how can I get my
boxes working as expected again.  I would love to write a
reasonable bug report but I have no idea against which package
so I could only issue this against general which is a little
bit naive.

Any help is very welcome



Reply to: