[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Looking for a autotools/libtool expert: Unnecessarily linked libraries

On Fri, Mar 03, 2006 at 05:27:05PM +0100, Frank Küster wrote:
> Steve Langasek <vorlon@debian.org> wrote:

> > For me, running the commands

> >   cd texk
> >   libtoolize -f -c
> >   cp /usr/share/aclocal/libtool.m4 libtool.m4
> >   autoconf

> > works, after editing kpathsea/withenable.ac to not try to use
> > AM_MAINTAINER_MODE (obviously irrelevant if you're not using automake). 
> > This eliminates dependencies on libcairo.so.2, libXrender.so.1, and
> > libX11.so.6 -- the rest of the dependencies seem to come from somewhere
> > other than libpoppler.

> Sorry, I can't reproduce that - I get errors from libtool at compile
> time (on sarge with libtool1.4 and autoconf 2.13) or at configure time
> (on sid where libtool1.4 doesn't exist and autoconf 2.59 is used).  Can
> you tell me exactly what you did and with which versions?

I used current sid versions of all packages: libtool 1.5.22-2, autoconf

I did exactly what I said I did -- edit kpathsea/withenable.ac to remove the
AM_MAINTAINER_MODE line, then run all of the commands I listed.  What error
do you get?

Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
vorlon@debian.org                                   http://www.debian.org/

Attachment: signature.asc
Description: Digital signature

Reply to: