[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: How to deal with dependencies/conflics on third party packages

hi joerg,

On Sun, Nov 20, 2005 at 10:23:58AM +0000, Joerg Sommer wrote:
> I've got a bug report (#336527) my package bootchart-view do not work
> with j2re1.3. But j2re1.3 is not in Debian. Can I set a conflict upon a
> packages that is not in Debian? But if it do not work with j2re1.3 it
> should more than ever not work with older version. But I would assume
> older version have different packages names. So I must add a list of
> packages names (j2re1.3 j2re1.2 j2re1.1), because I can not use the
> version clause (j2re1.3 (<< 1.3)). So what should I do?

adding conflicts lines for packages that don't exist in debian has
limited effectiveness imo.  even if there are packages (blackdown, or
whatever) for j2re, i would imagine that there's a large number of
users out there (myself included) who simply download the installer
from sun and installed java sans-package.

i'd consider simply adding a note to README.Debian/NEWS.Debian about
said problem, and being done with it altogether.  maybe leave the bug
open at wishlist+wontfix for reference too, i guess.



Attachment: signature.asc
Description: Digital signature

Reply to: