[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: How to deal with dependencies/conflics on third party packages

On Sun, Nov 20, 2005 at 10:23:58AM +0000, Joerg Sommer wrote:
> Hi,
> I've got a bug report (#336527) my package bootchart-view do not work
> with j2re1.3. But j2re1.3 is not in Debian. Can I set a conflict upon a
> packages that is not in Debian? But if it do not work with j2re1.3 it
> should more than ever not work with older version. But I would assume
> older version have different packages names. So I must add a list of
> packages names (j2re1.3 j2re1.2 j2re1.1), because I can not use the
> version clause (j2re1.3 (<< 1.3)). So what should I do?

Dont use a Conflicts: as this would deinstall j2re1.3 from the system.
The correct solution would be to check the version in your binary and
fail if the java version is too old.

BTW: the Debian Java Maintainers group is thinking about a more general
solution of this problem.

Escape the Java Trap with GNU Classpath!

Join the community at http://planet.classpath.org/

Reply to: