[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#318590: Bug#325643: libcurl and moc

On Fri, Sep 02, 2005 at 12:24:18PM +0200, Domenico Andreoli wrote:
> > >  - libcurl3              (GnuTLS, soname: libcurl.so.3)

> >   So the libcurl3 in sarge and etch will have ABI incompatibilities?

> at the release time of etch this problem will regard only
> external software. this kind of installations will be able to use
> libcurl3-openssl-dev package or switch to GnuTLS.

> is this reasonable enough?

No, definitely not.  You cannot change the ABI of an existing library
package, especially not one that's been in a stable release; you need
to rename it instead.

But no one has yet answered my question: *why* are there ABI differences
between the gnutls and openssl builds? 

Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
vorlon@debian.org                                   http://www.debian.org/

Attachment: signature.asc
Description: Digital signature

Reply to: